Ubuntu 20.10 で python エラーを解決して youtube-dl を使う

実はすごく簡単でした…!

使えるようにするためのコマンド!

このコマンドを実行しましょう.

$ sudo update-alternatives --install /usr/bin/python python /usr/bin/python3 1

参考にしたのは Qiita の記事.調べてみると Ubuntu のデフォルトの Python のバージョンが良くないっぽかったので,デフォルトで使用される Python のバージョンを明示的に Python 3系と指定してみたところ,うまく行きました!適当に youtube-dl を使用すると,たぶんこういうエラーが返ってくると思う.

$ youtube-dl https://www.youtube.com/watch?v=lfnd-KmHods
/usr/bin/env: `python': そのようなファイルやディレクトリはありません

これが (たぶん) Python のバージョンが違っていて,youtube-dl で Python を呼び出してもうまく動かないという意味のエラーなんだと思います… あるいは Python の2系と3系の両方がインストールされてるから,どっちを使うのかを明示しろ,という意味なのかもしれない.とにかく /usr/bin/env/python はありませんよ,と言ってる (んだよね?)

コメントを残す

Powered by WordPress.com. テーマ: Baskerville 2 by Anders Noren

ページ先頭へ ↑

%d人のブロガーが「いいね」をつけました。